GLSA-201908-25 : hostapd and wpa_supplicant: Denial of Service

Medium Nessus Plugin ID 127974

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201908-25 (hostapd and wpa_supplicant: Denial of Service)

A vulnerability was discovered in hostapd’s and wpa_supplicant’s eap_server/eap_server_pwd.c and eap_peer/eap_pwd.c files.
Impact :

An attacker could cause a possible Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All hostapd users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-wireless/hostapd-2.8' All wpa_supplicant users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-wireless/wpa_supplicant-2.8'

See Also

https://security.gentoo.org/glsa/201908-25

Plugin Details

Severity: Medium

ID: 127974

File Name: gentoo_GLSA-201908-25.nasl

Version: 1.1

Type: local

Published: 2019/08/20

Updated: 2019/08/20

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 5.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:hostapd, p-cpe:/a:gentoo:linux:wpa_supplicant, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2019/08/18

Vulnerability Publication Date: 2019/04/26

Reference Information

CVE: CVE-2019-11555

GLSA: 201908-25