Security Updates for Internet Explorer (August 2019)

high Nessus Plugin ID 127852
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The Internet Explorer installation on the remote host is affected by multiple vulnerabilities.

Description

The Internet Explorer installation on the remote host is missing security updates. It is, therefore, affected by multiple vulnerabilities :

- A security feature bypass vulnerability exists when Microsoft browsers improperly handle requests of different origins. The vulnerability allows Microsoft browsers to bypass Same-Origin Policy (SOP) restrictions, and to allow requests that should otherwise be ignored. An attacker who successfully exploited the vulnerability could force the browser to send data that would otherwise be restricted.
(CVE-2019-1192)

- A remote code execution vulnerability exists in the way that Microsoft browsers access objects in memory. The vulnerability could corrupt memory in a way that could allow an attacker to execute arbitrary code in the context of the current user. An attacker who successfully exploited the vulnerability could gain the same user rights as the current user. (CVE-2019-1193)

- A remote code execution vulnerability exists in the way that the scripting engine handles objects in memory in Internet Explorer. The vulnerability could corrupt memory in such a way that an attacker could execute arbitrary code in the context of the current user. An attacker who successfully exploited the vulnerability could gain the same user rights as the current user.
(CVE-2019-1133, CVE-2019-1194)

Solution

Microsoft has released the following security updates to address this issue:
-KB4512506
-KB4512518
-KB4512476
-KB4511872
-KB4512488

See Also

http://www.nessus.org/u?b7972a29

http://www.nessus.org/u?5235a5d1

http://www.nessus.org/u?127b7a44

http://www.nessus.org/u?79b786e1

http://www.nessus.org/u?1fc7ed0c

Plugin Details

Severity: High

ID: 127852

File Name: smb_nt_ms19_aug_internet_explorer.nasl

Version: 1.4

Type: local

Agent: windows

Published: 8/13/2019

Updated: 10/17/2019

Dependencies: smb_check_rollup.nasl, smb_hotfixes.nasl, ms_bulletin_checks_possible.nasl

Risk Information

CVSS Score Source: CVE-2019-1194

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.6

Temporal Score: 5.6

Vector: AV:N/AC:H/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:microsoft:windows

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Ease: No known exploits are available

Patch Publication Date: 8/13/2019

Vulnerability Publication Date: 8/13/2019

Reference Information

CVE: CVE-2019-1133, CVE-2019-1192, CVE-2019-1193, CVE-2019-1194

MSKB: 4512506, 4512518, 4512476, 4511872, 4512488

MSFT: MS19-4512506, MS19-4512518, MS19-4512476, MS19-4511872, MS19-4512488