Ansible Tower 3.3.x < 3.3.6 / 3.4.x < 3.4.4 / 3.5.x < 3.5.1 CRLF Vulnerability

Medium Nessus Plugin ID 127127

Synopsis

An IT monitoring application running on the remote host is affected by a Unauthorized Access vulnerability.

Description

The version of Ansible Tower running on the remote web server is 3.3.x prior to 3.3.6, 3.4.x prior to 3.4.4, or 3.5.x prior to 3.5.1. It is, therefore, affected by a CRLF injection vulnerability in the urllib2 library of python 2.x through 2.7.16 & python 3.x through 3.7.3.

Solution

Upgrade to Ansible Tower version 3.3.6, 3.4.4, 3.5.1 or later.

See Also

http://www.nessus.org/u?b98ff3bb

http://www.nessus.org/u?a90b57b1

http://www.nessus.org/u?e42f9a1e

Plugin Details

Severity: Medium

ID: 127127

File Name: ansible_tower_3_5_1.nasl

Version: 1.1

Type: combined

Family: CGI abuses

Published: 2019/08/05

Updated: 2019/08/05

Dependencies: 112214, 112215

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-9740

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3.0

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Vulnerability Information

CPE: cpe:/a:ansible:tower

Patch Publication Date: 2019/04/10

Vulnerability Publication Date: 2019/03/13

Reference Information

CVE: CVE-2019-9740

BID: 107466