Ansible Tower 3.x < 3.3.5 / 3.4.x < 3.4.3 Privilege Escalation Vulnerability

Medium Nessus Plugin ID 127126


An IT monitoring application running on the remote host is affected by a Unauthorized Access vulnerability.


The version of Ansible Tower running on the remote web server is 3.3.x prior to 3.3.5 or 3.4.x prior to 3.4.3. It is, therefore, affected by a anauthorized access vulnerability due to a RabbitMQ misconfiguration. The configuration does not set a secure channel for messaging celery workers, resulting in a leak of sensitive data, resulting in a potential privilege escalation vulnerability, as well as the ability to delete projects & files.


Upgrade to Ansible Tower version 3.3.5 / 3.4.3 or later.

See Also

Plugin Details

Severity: Medium

ID: 127126

File Name: ansible_tower_3_4_3.nasl

Version: 1.2

Type: combined

Family: CGI abuses

Published: 2019/08/05

Updated: 2019/10/18

Dependencies: 112214, 112215

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-3869

CVSS v2.0

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:ansible:tower

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/03/26

Vulnerability Publication Date: 2019/03/13

Reference Information

CVE: CVE-2019-3869

BID: 107854