Ansible Tower 3.x < 3.3.3 Unauthorized Access vulnerability

High Nessus Plugin ID 127125


An IT monitoring application running on the remote host is affected by a Unauthorized Access vulnerability.


The version of Ansible Tower running on the remote web server is 3.x prior to 3.3.3. It is, therefore, affected by an unauthorized access vulnerability due to a RabbitMQ misconfiguration. The configuration does not set a secure channel for messaging celery workers, resulting in a leak of sensitive data and the deletion of projects & files.


Upgrade to Ansible Tower version 3.3.3 or later.

See Also

Plugin Details

Severity: High

ID: 127125

File Name: ansible_tower_3_3_3.nasl

Version: 1.1

Type: combined

Family: CGI abuses

Published: 2019/08/05

Updated: 2019/08/05

Dependencies: 112214, 112215

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-16879

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:ansible:tower

Patch Publication Date: 2018/12/20

Vulnerability Publication Date: 2018/12/20

Reference Information

CVE: CVE-2018-16879

BID: 106310

IAVB: 2019-B-0068