Drupal 8.7.4 Access Bypass Vulnerability (SA-CORE-2019-008) (drupal-2019-07-17)

High Nessus Plugin ID 126952

Synopsis

A PHP application running on the remote web server is affected by a vulnerability.

Description

According to its self-reported version, the instance of Drupal running on the remote web server is 8.7.4. It is, therefore, affected by an access bypass condition when the experimental Workspaces module is enabled.

Note this vulnerability does not affect any release other than Drupal 8.7.4. Drupal 8.7.3 and earlier, Drupal 8.6.x and earlier, and Drupal 7.x are not affected.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Drupal version 8.7.5 or later.

See Also

https://www.drupal.org/sa-core-2019-008

https://www.drupal.org/core/experimental#beta

Plugin Details

Severity: High

ID: 126952

File Name: drupal_8_7_5.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 2019/07/23

Updated: 2019/07/25

Dependencies: 18638

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2019-6342

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: installed_sw/Drupal, Settings/ParanoidReport

Patch Publication Date: 2019/07/17

Vulnerability Publication Date: 2019/07/17

Reference Information

CVE: CVE-2019-6342

IAVA: 2019-A-0261