Debian DLA-1851-1 : openjpeg2 security update

Medium Nessus Plugin ID 126607

Synopsis

The remote Debian host is missing a security update.

Description

Two security vulnerabilities were discovered in openjpeg2, a JPEG 2000 image library.

CVE-2016-9112

A floating point exception or divide by zero in the function opj_pi_next_cprl may lead to a denial of service.

CVE-2018-20847

An improper computation of values in the function opj_get_encoding_parameters can lead to an integer overflow. This issue was partly fixed by the patch for CVE-2015-1239.

For Debian 8 'Jessie', these problems have been fixed in version 2.1.0-2+deb8u7.

We recommend that you upgrade your openjpeg2 packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2019/07/msg00010.html

https://packages.debian.org/source/jessie/openjpeg2

Plugin Details

Severity: Medium

ID: 126607

File Name: debian_DLA-1851.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2019/07/11

Updated: 2019/07/11

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libopenjp2-7, p-cpe:/a:debian:debian_linux:libopenjp2-7-dbg, p-cpe:/a:debian:debian_linux:libopenjp2-7-dev, p-cpe:/a:debian:debian_linux:libopenjp2-tools, p-cpe:/a:debian:debian_linux:libopenjp3d-tools, p-cpe:/a:debian:debian_linux:libopenjp3d7, p-cpe:/a:debian:debian_linux:libopenjpip-dec-server, p-cpe:/a:debian:debian_linux:libopenjpip-server, p-cpe:/a:debian:debian_linux:libopenjpip-viewer, p-cpe:/a:debian:debian_linux:libopenjpip7, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2019/07/10

Vulnerability Publication Date: 2016/10/29

Reference Information

CVE: CVE-2016-9112, CVE-2018-20847