Security Updates for Internet Explorer (July 2019)

High Nessus Plugin ID 126582

Synopsis

The Internet Explorer installation on the remote host is affected by multiple vulnerabilities.

Description

The Internet Explorer installation on the remote host is missing security updates. It is, therefore, affected by multiple vulnerabilities :

- A remote code execution vulnerability exists when Internet Explorer improperly accesses objects in memory.
The vulnerability could corrupt memory in such a way that an attacker could execute arbitrary code in the context of the current user. An attacker who successfully exploited the vulnerability could gain the same user rights as the current user. (CVE-2019-1063)

- A remote code execution vulnerability exists in the way that the scripting engine handles objects in memory in Internet Explorer. The vulnerability could corrupt memory in such a way that an attacker could execute arbitrary code in the context of the current user. An attacker who successfully exploited the vulnerability could gain the same user rights as the current user.
(CVE-2019-1004, CVE-2019-1056, CVE-2019-1059)

- A remote code execution vulnerability exists in the way that Microsoft browsers access objects in memory. The vulnerability could corrupt memory in a way that could allow an attacker to execute arbitrary code in the context of the current user. An attacker who successfully exploited the vulnerability could gain the same user rights as the current user. (CVE-2019-1104)

- A remote code execution vulnerability exists in the way the scripting engine handles objects in memory in Microsoft browsers. The vulnerability could corrupt memory in such a way that an attacker could execute arbitrary code in the context of the current user. An attacker who successfully exploited the vulnerability could gain the same user rights as the current user.
(CVE-2019-1001)

Solution

Microsoft has released the following security updates to address this issue:
-KB4507434
-KB4507448
-KB4507449
-KB4507452
-KB4507462

See Also

http://www.nessus.org/u?fedd67fe

http://www.nessus.org/u?94506c02

http://www.nessus.org/u?cbe675e9

http://www.nessus.org/u?d231fad3

http://www.nessus.org/u?01b80f6a

Plugin Details

Severity: High

ID: 126582

File Name: smb_nt_ms19_jul_internet_explorer.nasl

Version: 1.3

Type: local

Agent: windows

Published: 2019/07/09

Updated: 2019/08/16

Dependencies: 57033, 93962, 13855

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2019-1001

CVSS v2.0

Base Score: 7.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/o:microsoft:windows, cpe:/a:microsoft:ie

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Patch Publication Date: 2019/07/09

Vulnerability Publication Date: 2019/07/09

Reference Information

CVE: CVE-2019-1001, CVE-2019-1004, CVE-2019-1056, CVE-2019-1059, CVE-2019-1063, CVE-2019-1104

BID: 108979, 108982, 109006, 109007, 109008, 109009

MSKB: 4507434, 4507462, 4507449, 4507448, 4507452

MSFT: MS19-4507434, MS19-4507462, MS19-4507449, MS19-4507448, MS19-4507452