Apple iTunes for Windows < 12.9.5 Multiple Vulnerabilities (uncredentialed check)

High Nessus Plugin ID 126475

Synopsis

An application installed on the remote host is affected by multiple vulnerabilities

Description

The version of Apple iTunes for Windows installed on the remote Windows host is prior to 12.9.5. It is, therefore, affected by multiple vulnerabilities as referenced in the HT210124 advisory.

- An application may be able to gain elevated privileges (CVE-2019-8577)

- A maliciously crafted SQL query may lead to arbitrary code execution (CVE-2019-8600)

- A malicious application may be able to read restricted memory (CVE-2019-8598)

- A malicious application may be able to elevate privileges (CVE-2019-8602)

- Processing maliciously crafted web content may result in the disclosure of process memory (CVE-2019-8607)

- Processing maliciously crafted web content may lead to arbitrary code execution (CVE-2019-6237, CVE-2019-8571, CVE-2019-8583, CVE-2019-8584, CVE-2019-8586, CVE-2019-8587, CVE-2019-8594, CVE-2019-8595, CVE-2019-8596, CVE-2019-8597, CVE-2019-8601, CVE-2019-8608, CVE-2019-8609, CVE-2019-8610, CVE-2019-8611, CVE-2019-8615, CVE-2019-8619, CVE-2019-8622, CVE-2019-8623, CVE-2019-8628)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apple iTunes for Windows version 12.9.5 or later.

See Also

https://support.apple.com/en-us/HT210124

Plugin Details

Severity: High

ID: 126475

File Name: itunes_12_9_5_banner.nasl

Version: 1.3

Type: remote

Published: 2019/07/04

Updated: 2020/01/07

Dependencies: 20217

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2019-8600

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apple:itunes

Required KB Items: installed_sw/iTunes DAAP

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/05/09

Vulnerability Publication Date: 2019/05/09

Reference Information

CVE: CVE-2019-6237, CVE-2019-8571, CVE-2019-8577, CVE-2019-8583, CVE-2019-8584, CVE-2019-8586, CVE-2019-8587, CVE-2019-8594, CVE-2019-8595, CVE-2019-8596, CVE-2019-8597, CVE-2019-8598, CVE-2019-8600, CVE-2019-8601, CVE-2019-8602, CVE-2019-8607, CVE-2019-8608, CVE-2019-8609, CVE-2019-8610, CVE-2019-8611, CVE-2019-8615, CVE-2019-8619, CVE-2019-8622, CVE-2019-8623, CVE-2019-8628

BID: 108491, 108497

APPLE-SA: HT210124, APPLE-SA-2019-05-09