Debian DLA-1827-1 : gvfs security update

Medium Nessus Plugin ID 126054

Synopsis

The remote Debian host is missing a security update.

Description

Simon McVittie discovered a flaw in gvfs, the Gnome Virtual File System. The gvfsd daemon opened a private D-Bus server socket without configuring an authorization rule. A local attacker could connect to this server socket and issue D-Bus method calls.

(Note that the server socket only accepts a single connection, so the attacker would have to discover the server and connect to the socket before its owner does.)

For Debian 8 'Jessie', this problem has been fixed in version 1.22.2-1+deb8u1.

We recommend that you upgrade your gvfs packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2019/06/msg00014.html

https://packages.debian.org/source/jessie/gvfs

Plugin Details

Severity: Medium

ID: 126054

File Name: debian_DLA-1827.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2019/06/20

Updated: 2020/01/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.6

Temporal Score: 3.4

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:gvfs, p-cpe:/a:debian:debian_linux:gvfs-backends, p-cpe:/a:debian:debian_linux:gvfs-bin, p-cpe:/a:debian:debian_linux:gvfs-common, p-cpe:/a:debian:debian_linux:gvfs-daemons, p-cpe:/a:debian:debian_linux:gvfs-dbg, p-cpe:/a:debian:debian_linux:gvfs-fuse, p-cpe:/a:debian:debian_linux:gvfs-libs, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/06/19

Vulnerability Publication Date: 2019/06/11

Reference Information

CVE: CVE-2019-12795