Oracle Linux 6 / 7 : Unbreakable Enterprise kernel (ELSA-2019-4684) (SACK Panic) (SACK Slowness)

High Nessus Plugin ID 125963

Synopsis

The remote Oracle Linux host is missing one or more security updates.

Description

Description of changes:

[4.1.12-124.28.3.el7uek]
- Add CVE numbers for CVE-2019-11477 CVE-2019-11478 CVE-2019-11479 (Chuck Anderson) [Orabug: 29890820] {CVE-2019-11477} {CVE-2019-11478} {CVE-2019-11479} {CVE-2019-11477} {CVE-2019-11478} {CVE-2019-11479}
- tcp: fix fack_count accounting on tcp_shift_skb_data() (Joao Martins) [Orabug: 29890820]
- tcp: enforce tcp_min_snd_mss in tcp_mtu_probing() (Eric Dumazet) [Orabug: 29886598]

[4.1.12-124.28.2.el7uek]
- tcp: add tcp_min_snd_mss sysctl (Eric Dumazet) [Orabug: 29884306]
- tcp: tcp_fragment() should apply sane memory limits (Eric Dumazet) [Orabug: 29884306]
- tcp: limit payload size of sacked skbs (Eric Dumazet) [Orabug: 29884306]

Solution

Update the affected unbreakable enterprise kernel packages.

See Also

https://oss.oracle.com/pipermail/el-errata/2019-June/008828.html

https://oss.oracle.com/pipermail/el-errata/2019-June/008829.html

Plugin Details

Severity: High

ID: 125963

File Name: oraclelinux_ELSA-2019-4684.nasl

Version: 1.6

Type: local

Agent: unix

Published: 2019/06/18

Updated: 2020/01/10

Dependencies: 12634, 122878

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:oracle:linux:kernel-uek, p-cpe:/a:oracle:linux:kernel-uek-debug, p-cpe:/a:oracle:linux:kernel-uek-debug-devel, p-cpe:/a:oracle:linux:kernel-uek-devel, p-cpe:/a:oracle:linux:kernel-uek-doc, p-cpe:/a:oracle:linux:kernel-uek-firmware, cpe:/o:oracle:linux:6, cpe:/o:oracle:linux:7

Required KB Items: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/06/17

Vulnerability Publication Date: 2019/06/19

Reference Information

CVE: CVE-2019-11477, CVE-2019-11478, CVE-2019-11479