RHEL 6 : chromium-browser (RHSA-2019:1477)

high Nessus Plugin ID 125940

Synopsis

The remote Red Hat host is missing one or more security updates.

Description

An update for chromium-browser is now available for Red Hat Enterprise Linux 6 Supplementary.

Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

Chromium is an open source web browser, powered by WebKit (Blink).

This update upgrades Chromium to version 75.0.3770.80.

Security Fix(es) :

* chromium-browser: Use after free in ServiceWorker (CVE-2019-5828)

* chromium-browser: Use after free in Download Manager (CVE-2019-5829)

* chromium-browser: Incorrectly credentialed requests in CORS (CVE-2019-5830)

* chromium-browser: Incorrect map processing in V8 (CVE-2019-5831)

* chromium-browser: Incorrect CORS handling in XHR (CVE-2019-5832)

* chromium-browser: Inconsistent security UI placement (CVE-2019-5833)

* chromium-browser: Out of bounds read in Swiftshader (CVE-2019-5835)

* chromium-browser: Heap buffer overflow in Angle (CVE-2019-5836)

* chromium-browser: Cross-origin resources size disclosure in Appcache (CVE-2019-5837)

* chromium-browser: Overly permissive tab access in Extensions (CVE-2019-5838)

* chromium-browser: Incorrect handling of certain code points in Blink (CVE-2019-5839)

* chromium-browser: Popup blocker bypass (CVE-2019-5840)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Solution

Update the affected chromium-browser and / or chromium-browser-debuginfo packages.

See Also

https://access.redhat.com/errata/RHSA-2019:1477

https://access.redhat.com/security/cve/cve-2019-5828

https://access.redhat.com/security/cve/cve-2019-5829

https://access.redhat.com/security/cve/cve-2019-5830

https://access.redhat.com/security/cve/cve-2019-5831

https://access.redhat.com/security/cve/cve-2019-5832

https://access.redhat.com/security/cve/cve-2019-5833

https://access.redhat.com/security/cve/cve-2019-5835

https://access.redhat.com/security/cve/cve-2019-5836

https://access.redhat.com/security/cve/cve-2019-5837

https://access.redhat.com/security/cve/cve-2019-5838

https://access.redhat.com/security/cve/cve-2019-5839

https://access.redhat.com/security/cve/cve-2019-5840

Plugin Details

Severity: High

ID: 125940

File Name: redhat-RHSA-2019-1477.nasl

Version: 1.8

Type: local

Agent: unix

Published: 6/17/2019

Updated: 5/29/2020

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:chromium-browser, p-cpe:/a:redhat:enterprise_linux:chromium-browser-debuginfo, cpe:/o:redhat:enterprise_linux:6

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 6/17/2019

Vulnerability Publication Date: 6/27/2019

Reference Information

CVE: CVE-2019-5828, CVE-2019-5829, CVE-2019-5830, CVE-2019-5831, CVE-2019-5832, CVE-2019-5833, CVE-2019-5835, CVE-2019-5836, CVE-2019-5837, CVE-2019-5838, CVE-2019-5839, CVE-2019-5840

RHSA: 2019:1477