Debian DSA-4463-1 : znc - security update

Medium Nessus Plugin ID 125929

Synopsis

The remote Debian host is missing a security-related update.

Description

Two vulnerabilities were discovered in the ZNC IRC bouncer which could result in remote code execution (CVE-2019-12816 ) or denial of service via invalid encoding (CVE-2019-9917 ).

Solution

Upgrade the znc packages.

For the stable distribution (stretch), these problems have been fixed in version 1.6.5-1+deb9u2.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=925285

https://security-tracker.debian.org/tracker/CVE-2019-12816

https://security-tracker.debian.org/tracker/CVE-2019-9917

https://security-tracker.debian.org/tracker/source-package/znc

https://packages.debian.org/source/stretch/znc

https://www.debian.org/security/2019/dsa-4463

Plugin Details

Severity: Medium

ID: 125929

File Name: debian_DSA-4463.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2019/06/17

Updated: 2019/06/18

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:znc, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2019/06/14

Vulnerability Publication Date: 2019/03/27

Reference Information

CVE: CVE-2019-12816, CVE-2019-9917

DSA: 4463