Joomla 3.6.x < 3.9.7 Multiple Vulnerabilites
High Nessus Plugin ID 125923
SynopsisA PHP application running on the remote web server is affected by multiple vulnerabilities.
DescriptionAccording to its self-reported version, the instance of Joomla! running on the remote web server is 3.6.x prior to 3.9.7. It is, therefore, affected by the following vulnerabilities:
- Joomla versions 3.8.13 prior to 3.9.7 are affected by a vulnerability where a non-admin user may manipulate the update server URL of the com_joomlaupdate component. An authenticated, remote attacker could exploit this to cause an update to be pulled from a malicious server (CVE-2019-12764).
- Joomla versions 3.9.x prior to 3.9.7 are affected by a CSV injection vulnerability due to insufficient validation of user-supplied input. An unauthenticated, remote attacker may exploit this by submitting special characters to the com_actionlogs component. When the resulting CSV file produced by Joomla is opened by a spreadsheet program these special characters are interpretted as a formula (CVE-2019-12765).
- Joomla versions 3.6.x prior to 3.9.6 are affected by a cross-site scripting (XSS) vulnerability due to improper validation of user-supplied input before returning it to users. An unauthenticated, remote attacker can exploit this, by convincing a user to click a specially crafted URL, to execute arbitrary script code in a user's browser session (CVE-2019-12766).
Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.
SolutionUpgrade to Joomla! version 3.9.8 or later (Note: Joomla released security fixes for the above vulnerabilites in 3.9.7. However, this release introduced an additional bug so it is recommended to upgrade your installation to 3.9.8).