VMware Workstation (Linux) 15.0.x < 15.1.0 Use After Free Vulnerability (VMSA-2019-0009)

High Nessus Plugin ID 125883

Synopsis

A virtualization application installed on the remote Linux host is affected by a use after free vulnerability

Description

The version of VMware Workstation installed on the remote Linux host is 15.0.x prior to 15.1.0. It is, therefore, affected by a use after free vulnerability in the Advanced Linux Sounds Architecture Backend. An authenticated, local attacker can exploit this, in conjunction with other issues, to execute arbitrary code.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update to VMware Workstation version 15.1.0, or later.

See Also

https://www.vmware.com/security/advisories/VMSA-2019-0009.html

Plugin Details

Severity: High

ID: 125883

File Name: vmware_workstation_vmsa_2019_0009.nasl

Version: 1.3

Type: local

Family: General

Published: 2019/06/14

Updated: 2019/10/18

Dependencies: 71053

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2019-5525

CVSS v2.0

Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:workstation

Required KB Items: installed_sw/VMware Workstation

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/05/14

Vulnerability Publication Date: 2019/06/06

Reference Information

CVE: CVE-2019-5525

BID: 108674

VMSA: 2019-0009