phpMyAdmin 4.x < 4.9.0 CSRF vulnerablity (PMASA-2019-4)

Medium Nessus Plugin ID 125856

Synopsis

The remote web server hosts a PHP application that is affected by a CSRF vulnerability.

Description

According to its self-reported version number, the phpMyAdmin application hosted on the remote web server is 4.x prior to 4.9.0. It is, therefore, affected by a cross-site request forgery (XSRF) vulnerability. A remote attacker can exploit this by tricking a user into visiting a specially crafted web page, allowing the attacker to disclose sensitive information, impersonate the user's identity, or inject malicious content into the victim's web browser.

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to phpMyAdmin version 4.9.0 or later.
Alternatively, apply the patches referenced in the vendor advisories.

See Also

http://www.nessus.org/u?66181e00

Plugin Details

Severity: Medium

ID: 125856

File Name: phpmyadmin_pmasa_2019_4.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 2019/06/13

Updated: 2019/06/18

Dependencies: 17219

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-12616

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.4

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 6.5

Temporal Score: 5.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Required KB Items: www/PHP, installed_sw/phpMyAdmin

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/06/04

Vulnerability Publication Date: 2019/06/04

Reference Information

CVE: CVE-2019-12616

BID: 108619