phpMyAdmin prior to 4.8.6 SQLi vulnerablity (PMASA-2019-3)

High Nessus Plugin ID 125855

Synopsis

The remote web server hosts a PHP application that is affected by SQLi vulnerability.

Description

According to its self-reported version number, the phpMyAdmin application hosted on the remote web server is prior to 4.8.6. It is, therefore, affected by a SQL injection (SQLi) vulnerability that exists in designer feature of phpMyAdmin. An unauthenticated, remote attacker can exploit this to inject or manipulate SQL queries in the back-end database, resulting in the disclosure or manipulation of arbitrary data.

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to phpMyAdmin version 4.8.6 or later.
Alternatively, apply the patches referenced in the vendor advisories.

See Also

http://www.nessus.org/u?c9d7fc8c

Plugin Details

Severity: High

ID: 125855

File Name: phpmyadmin_pmasa_2019_3.nasl

Version: 1.1

Type: remote

Family: CGI abuses

Published: 2019/06/13

Updated: 2019/06/13

Dependencies: 17219

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2019-11768

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Required KB Items: www/PHP, installed_sw/phpMyAdmin

Patch Publication Date: 2019/05/06

Vulnerability Publication Date: 2019/05/06

Reference Information

CVE: CVE-2019-11768

BID: 108617