Debian DLA-1817-1 : libgd2 security update

High Nessus Plugin ID 125837

Synopsis

The remote Debian host is missing a security update.

Description

An unitialized read was discovered in the XBM support of libgd2, a library for programmatic graphics creation and manipulation. The unitialized read might lead to information disclosure.

For Debian 8 'Jessie', this problem has been fixed in version 2.1.0-5+deb8u13.

We recommend that you upgrade your libgd2 packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2019/06/msg00003.html

https://packages.debian.org/source/jessie/libgd2

Plugin Details

Severity: High

ID: 125837

File Name: debian_DLA-1817.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2019/06/12

Updated: 2019/06/12

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libgd-dbg, p-cpe:/a:debian:debian_linux:libgd-dev, p-cpe:/a:debian:debian_linux:libgd-tools, p-cpe:/a:debian:debian_linux:libgd2-noxpm-dev, p-cpe:/a:debian:debian_linux:libgd2-xpm-dev, p-cpe:/a:debian:debian_linux:libgd3, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2019/06/11

Reference Information

CVE: CVE-2019-11038