WordPress < 2.0.2 Multiple Cross-Site Scripting (XSS) Vulnerabilities

Medium Nessus Plugin ID 125680


A PHP application running on the remote web server is affected by multiple cross-site scripting (XSS)vulnerabilities.


According to its self-reported version number, the WordPress application running on the remote web server is prior to 2.0.2. It is, therefore, affected by multiple cross-site scripting (XSS) vulnerabilities due to improper validation of user-supplied input before returning it to users. An unauthenticated, remote attacker can exploit this, by convincing a user to click a specially crafted URL, to execute arbitrary script code in a user's browser session.

Note the vulnerabilities fixed in this release were reported to and addressed by the WordPress development team without disclosure. For more information see the linked security advisory


Upgrade to WordPress version 2.0.2 or later.

See Also


Plugin Details

Severity: Medium

ID: 125680

File Name: wordpress_2_0_2.nasl

Version: 1.1

Type: remote

Family: CGI abuses

Published: 2019/06/04

Updated: 2019/06/04

Dependencies: 18297

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: manual

CVSS Score Rationale: Tenable score for xss

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3.0

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: www/PHP, installed_sw/WordPress, Settings/ParanoidReport

Patch Publication Date: 2006/03/10

Vulnerability Publication Date: 2006/03/10