PHP 7.1.x < 7.1.30 Multiple Vulnerabilities.

Medium Nessus Plugin ID 125640

Synopsis

An application installed on the remote host is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP running on the remote web server is 7.1.x prior to 7.1.30.
It is, therefore, affected by the following vulnerabilities:

- An uninitialized vulnerability exists in gdImageCreateFromXbm due to sscanf method not being able to read a hex value. An attacker may be able exploit this issue, to cause the disclose of sensitive information. (CVE-2019-11038)

- An out of bounds read vulnerability exists in iconv.c:_php_iconv_mime_decode() due to integer overflow.
An attacker may be able exploit this issue, to cause the disclose of sensitive information. (CVE-2019-11039)

- A heap-based buffer overflow condition exists on php_jpg_get16. An attacker can exploit this, to cause a denial of service condition or the execution of arbitrary code. (CVE-2019-11040)

Solution

Upgrade to PHP version 7.1.30 or later.

See Also

http://php.net/ChangeLog-7.php#7.1.30

Plugin Details

Severity: Medium

ID: 125640

File Name: php_7_1_30.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 2019/05/31

Updated: 2019/09/06

Dependencies: 48243

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-11038

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

CVSS v3.0

Base Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Patch Publication Date: 2019/05/30

Vulnerability Publication Date: 2019/05/30

Reference Information

CVE: CVE-2019-11038, CVE-2019-11039, CVE-2019-11040

BID: 108514, 108520, 108525