Poppler <= 0.76.1 Heap Buffer Overflow Vulnerability

Medium Nessus Plugin ID 125638

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 6.7

Synopsis

A package installed on the remote host is affected by a heap buffer overflow vulnerability.

Description

The version of Poppler installed on the remote host is prior or equal to 0.76.1. It is, therefore, affected by a heap-based buffer overflow vulnerability due to a flaw in the JPEG handling code. An unauthenticated, remote attacker can exploit this, via a specially crafted file, to cause a denial of service condition or execution of arbitrary code.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to a patched version of Poppler once it is available.

See Also

https://gitlab.freedesktop.org/poppler/poppler/issues/768

Plugin Details

Severity: Medium

ID: 125638

File Name: poppler_0_761.nasl

Version: 1.3

Type: local

Agent: unix macosx

Family: Misc.

Published: 2019/05/31

Updated: 2019/10/30

Dependencies: 83991, 12634

Risk Information

Risk Factor: Medium

VPR Score: 6.7

CVSS Score Source: CVE-2019-12293

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:freedesktop:poppler

Required KB Items: Host/local_checks_enabled

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/05/22

Vulnerability Publication Date: 2019/05/22

Reference Information

CVE: CVE-2019-12293

BID: 108457