Symantec Content Analysis < 2.3.1.1 affected by Multiple Vulnerabilities (SYMSA1410)

critical Nessus Plugin ID 125637

Synopsis

The remote host is running a version of Symantec Content Analysis that is affected by Multiple Vulnerabilities

Description

The version of Symantec Content Analysis running on the remote host is prior to version 2.3.1.1. It is, therefore, affected by multiple vulnerabilities:

- A vulnerability in Apache httpd 2.2.x before 2.2.33 and 2.4.x before 2.4.26, mod_mime can read one byte past the end of a buffer when sending a malicious Content-Type response header. (CVE-2017-7679)

- A vulnerability in Apache httpd 2.2.x before 2.2.33 and 2.4.x before 2.4.26, mod_ssl may dereference a NULL pointer when third-party modules call ap_hook_process_connection() during an HTTP request to an HTTPS port. (CVE-2017-3169)

Solution

Refer to vendor advisory (Symantec SYMSA1410) for suggested workaround, or upgrade to an unaffected version.

See Also

http://www.nessus.org/u?db8511d5

Plugin Details

Severity: Critical

ID: 125637

File Name: symantec_content_analysis_SYMSA1410.nasl

Version: 1.2

Type: local

Family: Misc.

Published: 5/31/2019

Updated: 10/30/2019

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2017-7679

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: x-cpe:/h:symantec:content_analysis, x-cpe:/h:bluecoat:content_analysis

Required KB Items: installed_sw/Symantec Content Analysis

Exploit Ease: No known exploits are available

Patch Publication Date: 7/20/2017

Vulnerability Publication Date: 6/6/2017

Reference Information

CVE: CVE-2017-3169, CVE-2017-7679

BID: 99170, 99134