Apache ZooKeeper < 3.4.14 / 3.5.x < 3.5.5 Information Disclosure

medium Nessus Plugin ID 125635
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote Apache ZooKeeper server is affected by an information disclosure vulnerability.


The version of Apache ZooKeeper listening on the remote host is prior to 3.4.14 or 3.5.x prior to 3.5.5. It is, therefore, affected by an information disclosure vulnerability in ZooKeeper's getACL() command as a result of not checking requester permissions. An unauthenticated, remote attacker can exploit this to disclose potentially sensitive information.


Update to Apache ZooKeeper 3.4.14 or 3.5.5 or later.

See Also



Plugin Details

Severity: Medium

ID: 125635

File Name: apache_zookeeper_3_5_5.nasl

Version: 1.2

Type: combined

Family: Misc.

Published: 5/31/2019

Updated: 10/18/2019

Dependencies: apache_zookeeper_detect.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2019-0201


Risk Factor: Low

Score: 3.6


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: Medium

Base Score: 5.9

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:zookeeper

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 5/23/2019

Vulnerability Publication Date: 5/23/2019

Reference Information

CVE: CVE-2019-0201

BID: 104253

IAVB: 2019-B-0041