Artifex Ghostscript < 9.27 PostScript Security Bypass Vulnerability

high Nessus Plugin ID 125631
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Windows host contains a library that is affected by a security bypass vulnerability.

Description

The version of Artifex Ghostscript installed on the remote Windows host is prior to 9.27. It is, therefore, affected by a security bypass vulnerability due to some privileged operators remained accessible from various places after the CVE-2019-6116 fix. An authenticated, remote attacker can exploit this, via specially crafted PostScript file, to access the file system outside of the constrains imposed by -dSAFER.

Solution

Update to 9.27.

See Also

https://www.ghostscript.com/Ghostscript_9.27.html

Plugin Details

Severity: High

ID: 125631

File Name: ghostscript_9_27.nasl

Version: 1.3

Type: local

Agent: windows

Family: Windows

Published: 5/31/2019

Updated: 10/30/2019

Dependencies: ghostscript_detect.nbin

Risk Information

CVSS Score Source: CVE-2019-3839

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:artifex:ghostscript, cpe:/a:artifex:gpl_ghostscript

Required KB Items: installed_sw/Ghostscript

Exploit Ease: No known exploits are available

Patch Publication Date: 4/4/2019

Vulnerability Publication Date: 1/31/2019

Reference Information

CVE: CVE-2019-3839

BID: 990682