WordPress < 4.9.9 Remote Code Execution Vulnerabilities

Medium Nessus Plugin ID 125597


A PHP application running on the remote web server is affected by remote code execution vulnerabilities.


According to its self-reported version number, the WordPress application running on the remote web server is prior to 4.9.9. It is, therefore, affected by remote command execution vulnerabilities in its thumbnail processing component due to insufficient validation of user input. An authenticated, remote attacker can exploit this, by uploading a malicious thumbnail, to execute arbitrary commands. (CVE-2017-1000600, CVE-2018-1000773).

Note that WordPress originally issued a fix for CVE-2017-1000600 but this fix was deemed insufficient and exploitation was still possible. Thus, CVE-2018-1000773 was opened and addressed in version 4.9.9.


Upgrade to WordPress version 4.9.9 or later.

See Also


Plugin Details

Severity: Medium

ID: 125597

File Name: wordpress_4_9_9.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 2019/05/30

Updated: 2019/10/30

Dependencies: 18297

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2017-1000600

CVSS v2.0

Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: www/PHP, installed_sw/WordPress, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/12/12

Vulnerability Publication Date: 2018/06/09

Reference Information

CVE: CVE-2017-1000600, CVE-2018-1000773

BID: 105305, 105306