WordPress < 5.0.4 Directory Traversal Vulnerability

Medium Nessus Plugin ID 125596


A PHP application running on the remote web server is affected by a directory traversal vulnerability.


According to its self-reported version number, the WordPress application running on the remote web server is prior to 5.0.4. It is, therefore, affected by a directory traversal vulnerability in its wp_crop_image() component. An authenticated, remote attacker can exploit this, by sending a URI that contains directory traversal characters, to disclose the contents of files located outside of the server's restricted path.


Upgrade to WordPress version 5.0.4 or later.

See Also


Plugin Details

Severity: Medium

ID: 125596

File Name: wordpress_5_0_4.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 2019/05/30

Updated: 2019/06/04

Dependencies: 18297

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-8943

CVSS v2.0

Base Score: 4

Temporal Score: 3.3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 6.5

Temporal Score: 6

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: www/PHP, installed_sw/WordPress, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/03/13

Vulnerability Publication Date: 2019/02/19

Exploitable With

Metasploit (WordPress Crop-image Shell Upload)

Reference Information

CVE: CVE-2019-8943

BID: 107089