Ubuntu 14.04 LTS : sudo vulnerability (USN-3968-2)

High Nessus Plugin ID 125593

Synopsis

The remote Ubuntu host is missing one or more security-related patches.

Description

USN-3968-1 fixed a vulnerability in Sudo. This update provides the corresponding update for Ubuntu 14.04 ESM.

Original advisory details :

It was discovered that Sudo did not properly parse the contents of /proc/[pid]/stat when attempting to determine its controlling tty. A local attacker in some configurations could possibly use this to overwrite any file on the filesystem, bypassing intended permissions.
(CVE-2017-1000368).

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected sudo and / or sudo-ldap packages.

See Also

https://usn.ubuntu.com/3968-2/

Plugin Details

Severity: High

ID: 125593

File Name: ubuntu_USN-3968-2.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2019/05/30

Updated: 2019/05/30

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 8.2

Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:sudo, p-cpe:/a:canonical:ubuntu_linux:sudo-ldap, cpe:/o:canonical:ubuntu_linux:14.04

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Patch Publication Date: 2019/05/29

Vulnerability Publication Date: 2017/06/05

Reference Information

CVE: CVE-2017-1000368

USN: 3968-2