Atlassian Crowd 2.1.x < 3.0.5 / 3.1.x < 3.1.6 / 3.2.x < 3.2.8 / 3.3.x < 3.3.5 / 3.4.x < 3.4.4 RCE Vulnerability

Critical Nessus Plugin ID 125477

Synopsis

The version of Atlassian Crowd installed on the remote host is affected by an remote code execution (RCE) vulnerability.

Description

The version of Atlassian Crowd installed on the remote host is 2.1.x prior to 3.0.5, 3.1.x prior to 3.1.6, 3.2.x prior to 3.2.8, 3.3.x prior to 3.3.5 or 3.4.x prior to 3.4.4. It is, therefore, affected by a remote code execution (RCE) vulnerability. An unauthenticated, remote attacker can exploit this, by using pdkinstall development plugin, to install arbitrary plugins, which permits remote code execution.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to version 3.0.5, 3.1.6, 3.2.8, 3.3.5, 3.4.4 or later.

See Also

http://www.nessus.org/u?f66fbb1c

Plugin Details

Severity: Critical

ID: 125477

File Name: crowd_3_4_4.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 2019/05/28

Updated: 2019/08/23

Dependencies: 11936, 67175

Risk Information

Risk Factor: Critical

CVSS Score Source: CVE-2019-11580

CVSS v2.0

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:atlassian:crowd

Required KB Items: www/crowd

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/05/22

Vulnerability Publication Date: 2019/05/22

Exploitable With

Core Impact

Reference Information

CVE: CVE-2019-11580