Fedora 30 : webkit2gtk3 (2019-f18fb0f37d)

High Nessus Plugin ID 125276

Synopsis

The remote Fedora host is missing a security update.

Description

- Fix rendering of emojis copy-pasted from GTK emoji chooser.

- Fix space characters not being rendered with some CJK fonts.

- Fix adaptive streaming playback with older GStreamer versions.

- Set a maximum zoom level for pinch zooming gesture.

- Fix navigation gesture to not interfere with scrolling.

- Fix SSE2 detection at compile time, ensuring the right flags are passed to the compiler.

- Fix several crashes and rendering issues.

- Translation updates: Danish, Spanish, Ukrainian.

- Security fixes: CVE-2019-8595, CVE-2019-8607, CVE-2019-8615.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora update system website.
Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected webkit2gtk3 package.

See Also

https://bodhi.fedoraproject.org/updates/FEDORA-2019-f18fb0f37d

Plugin Details

Severity: High

ID: 125276

File Name: fedora_2019-f18fb0f37d.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2019/05/20

Updated: 2019/09/23

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:webkit2gtk3, cpe:/o:fedoraproject:fedora:30

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2019/05/20

Reference Information

CVE: CVE-2019-8595, CVE-2019-8607, CVE-2019-8615