Citrix ADC and Citrix NetScaler Gateway buffer overflow vulnerability (CTX249976)

Medium Nessus Plugin ID 125258

Synopsis

The remote device is affected by a buffer overflow vulnerability.

Description

The remote Citrix ADC or Citrix NetScaler Gateway device is affected by a buffer overflow vulnerability.
An attacker may be able to leverage this vulnerability which will result in a denial of service in a specific configuration.
Please refer to advisory CTX249976 for more information.

Solution

Upgrade to Citrix NetScaler Gateway version 11.1 build 59.10 / 12.0 build 59.8 / 12.1 build 49.23 or refer to vendor documentation for configuration mitigation.

See Also

http://www.nessus.org/u?7d161693

Plugin Details

Severity: Medium

ID: 125258

File Name: citrix_netscaler_CTX249976.nasl

Version: 1.1

Type: combined

Family: CGI abuses

Published: 2019/05/17

Updated: 2019/05/17

Dependencies: 73204

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-12044

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/o:citrix:netscaler_access_gateway_firmware

Required KB Items: Host/NetScaler/Detected, Settings/ParanoidReport

Patch Publication Date: 2019/05/13

Vulnerability Publication Date: 2019/05/13

Reference Information

CVE: CVE-2019-12044