Mac OS X Multiple Vulnerabilities (Security Update 2003-12-19)

Critical Nessus Plugin ID 12516


The remote host is missing a Mac OS X security update.


The remote host is missing Security Update 2003-12-19.

This security update includes the following components :

- AFP Server
- cd9600.util
- Directory Services
- fetchmail
- fs_usage
- rsync
- System Initialization

For MacOS X 10.3, it also includes :

- ASN.1 Decoding for PKI

This update contains various fixes which may allow an attacker to execute arbitrary code on the remote host.


Install security update 2003-12-19. For more information, see

See Also

Plugin Details

Severity: Critical

ID: 12516

File Name: macosx_SecUpd20031219.nasl

Version: $Revision: 1.16 $

Type: local

Agent: macosx

Published: 2004/07/06

Modified: 2016/05/20

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 9

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:ND/RC:ND

Vulnerability Information

CPE: cpe:/o:apple:mac_os_x

Required KB Items: Host/MacOSX/packages

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2003/12/19

Vulnerability Publication Date: 2003/10/20

Exploitable With


Reference Information

CVE: CVE-2003-1007, CVE-2003-1008, CVE-2003-1010, CVE-2003-1011, CVE-2003-1006, CVE-2003-0962, CVE-2003-1009, CVE-2003-0851, CVE-2003-0792

OSVDB: 2699, 2765, 2868, 2898, 3043, 7069, 7070, 7097, 7098