Debian DSA-4442-1 : ghostscript - security update

high Nessus Plugin ID 124780

Synopsis

The remote Debian host is missing a security-related update.

Description

A vulnerability was discovered in Ghostscript, the GPL PostScript/PDF interpreter, which may result in denial of service or the execution of arbitrary code if a malformed Postscript file is processed (despite the -dSAFER sandbox being enabled).

Solution

Upgrade the ghostscript packages.

For the stable distribution (stretch), this problem has been fixed in version 9.26a~dfsg-0+deb9u3.

See Also

https://security-tracker.debian.org/tracker/source-package/ghostscript

https://packages.debian.org/source/stretch/ghostscript

https://www.debian.org/security/2019/dsa-4442

Plugin Details

Severity: High

ID: 124780

File Name: debian_DSA-4442.nasl

Version: 1.3

Type: local

Agent: unix

Published: 5/13/2019

Updated: 1/17/2020

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ghostscript, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 5/12/2019

Vulnerability Publication Date: 5/16/2019

Reference Information

CVE: CVE-2019-3839

DSA: 4442