RHEL 2.1 : metamail (RHSA-2004:073)

High Nessus Plugin ID 12471


The remote Red Hat host is missing a security update.


Updated metamail packages that fix a number of vulnerabilities are now available.

Metamail is a system for handling multimedia mail.

Ulf Harnhammar discovered two format string bugs and two buffer overflow bugs in versions of Metamail up to and including 2.7. An attacker could create a carefully-crafted message such that when it is opened by a victim and parsed through Metamail, it runs arbitrary code as the victim. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the names CVE-2004-0104 (format strings) and CVE-2004-0105 (buffer overflows) to these issues.

Users of Red Hat Enterprise Linux 2.1 are advised to upgrade to these erratum packages, which contain a backported security patch and are not vulnerable to these issues. Please note that Red Hat Enterprise Linux 3 does not contain Metamail and is therefore not vulnerable to these issues.

Red Hat would like to thank Ulf Harnhammar for the notification and patch for these issues.


Update the affected metamail package.

See Also





Plugin Details

Severity: High

ID: 12471

File Name: redhat-RHSA-2004-073.nasl

Version: $Revision: 1.22 $

Type: local

Agent: unix

Published: 2004/07/06

Modified: 2016/12/28

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:metamail, cpe:/o:redhat:enterprise_linux:2.1

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Patch Publication Date: 2004/02/18

Vulnerability Publication Date: 2004/02/18

Reference Information

CVE: CVE-2004-0104, CVE-2004-0105

OSVDB: 3988

RHSA: 2004:073