Joomla! prior to 3.9.6 Cross-Site Scripting (XSS) Vulnerability

Medium Nessus Plugin ID 124682

Synopsis

The remote web server is running a version of Joomla! CMS which is affected by a cross-site scripting (XSS) vulnerability.

Description

According to its self-reported version number, the Joomla! installation running on the remote web server is prior to 3.9.6.

In versions prior to 3.9.6, a cross-site scripting (XSS) vulnerability exists due to improper validation of user-supplied input before returning it to users. An unauthenticated, remote attacker can exploit this, by convincing a user to click a specially crafted URL, to execute arbitrary script code in a user's browser session.

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Joomla! version 3.9.6 or later.

See Also

http://www.nessus.org/u?3beb3d34

https://developer.joomla.org/security-centre.html

Plugin Details

Severity: Medium

ID: 124682

File Name: joomla_396_xss.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 2019/05/08

Updated: 2019/06/20

Dependencies: 21142

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-11809

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3.0

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Vulnerability Information

CPE: cpe:/a:joomla:joomla\!

Required KB Items: installed_sw/Joomla!, www/PHP, Settings/ParanoidReport

Patch Publication Date: 2019/05/07

Vulnerability Publication Date: 2019/05/07

Reference Information

CVE: CVE-2019-11809