RHEL 2.1 / 3 : mod_python (RHSA-2004:058)

Medium Nessus Plugin ID 12464


The remote Red Hat host is missing a security update.


Updated mod_python packages that fix a denial of service vulnerability are now available for Red Hat Enterprise Linux.

mod_python embeds the Python language interpreter within the Apache httpd server.

A bug has been found in mod_python versions 2.7.10 and earlier that can lead to a denial of service vulnerability. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2003-0973 to this issue.

Although Red Hat Enterprise Linux shipped with a version of mod_python that contains this bug, our testing was unable to trigger the denial of service vulnerability. However, mod_python users are advised to upgrade to these errata packages, which contain a backported patch that corrects this bug.


Update the affected mod_python package.

See Also





Plugin Details

Severity: Medium

ID: 12464

File Name: redhat-RHSA-2004-058.nasl

Version: $Revision: 1.19 $

Type: local

Agent: unix

Published: 2004/07/06

Modified: 2016/12/28

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:mod_python, cpe:/o:redhat:enterprise_linux:2.1, cpe:/o:redhat:enterprise_linux:3

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Patch Publication Date: 2004/02/26

Reference Information

CVE: CVE-2003-0973, CVE-2004-0096

RHSA: 2004:058