Kubernetes 1.3.x < 1.7.14 / 1.8.x < 1.8.9 / 1.9.x < 1.9.4 multiple vulnerabilities

Medium Nessus Plugin ID 124590

Synopsis

The remote host contains an application affected by multiple vulnerability.

Description

The version of Kubernetes installed on the remote host is version 1.3.x prior to 1.7.14, 1.8.x prior to 1.8.9 or 1.9.x prior to 1.9.4. It is, therefore, affected by multiple vulnerabilities.

- An arbitrary file access vulnerability exists in containers using subpath volume mounts. An authenticated, local attacker can exploit this to access arbitrary files or directories including the host's filesystem.
(CVE-2017-1002101)

- An arbitrary file deletion vulnerability exists in containers using a secret, configMap, projected or downwardAPI volume. An unauthenticated, local attacker can exploit this to delete arbitrary files or directories from the nodes where they are running. (CVE-2017-1002102)

Solution

Upgrade to Kubernetes 1.7.14, 1.8.9, 1.9.4 or later, please refer to the vendor advisory.

See Also

http://www.nessus.org/u?7000232d

Plugin Details

Severity: Medium

ID: 124590

File Name: kubernetes_1_9_4_multiple_vulnerabilities.nasl

Version: 1.3

Type: local

Agent: unix

Family: Misc.

Published: 2019/05/03

Updated: 2019/10/30

Dependencies: 112063

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2017-1002102

CVSS v2.0

Base Score: 6.3

Temporal Score: 4.7

Vector: CVSS2#AV:L/AC:M/Au:N/C:N/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.6

Temporal Score: 4.9

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:C/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:kubernetes:kubernetes, cpe:/a:google:kubernetes

Required KB Items: installed_sw/Kubernetes

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/12/18

Vulnerability Publication Date: 2018/03/13

Reference Information

CVE: CVE-2017-1002101, CVE-2017-1002102