GPON ONT Home Gateway Remote Enabling of Telnet (CVE-2019-3917)

high Nessus Plugin ID 124240
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is affected by an authenticated remote code execution vulnerability.

Description

An issue was discovered in GPON ONT Home Gateway web API. The API exposes a HTTP endpoint which when requested by an attacker starts the telnetd daemon on the device.

Solution

Consult your vendor for a patch or a workaround.

See Also

https://www.tenable.com/security/research/tra-2019-09

Plugin Details

Severity: High

ID: 124240

File Name: gpon_cve-2019-3917.nbin

Version: 1.27

Type: remote

Family: Web Servers

Published: 4/24/2019

Updated: 10/19/2021

Dependencies: gpon_router_detect.nbin, telnet.nasl

Risk Information

CVSS Score Source: CVE-2019-3917

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.9

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:dasannetworks:gpon_router

Required KB Items: installed_sw/GPON HG

Exploit Available: true

Exploit Ease: Exploits are available

Exploited by Nessus: true

Vulnerability Publication Date: 2/27/2019

Reference Information

CVE: CVE-2019-3917