GLSA-201904-23 : GLib: Multiple vulnerabilities

Medium Nessus Plugin ID 124228

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201904-23 (GLib: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in GLib. Please review the referenced bug for details.
Impact :

Please review the referenced bugs for details.
Workaround :

There is no known workaround at this time.

Solution

All GLib users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-libs/glib-2.56.4'

See Also

https://security.gentoo.org/glsa/201904-23

Plugin Details

Severity: Medium

ID: 124228

File Name: gentoo_GLSA-201904-23.nasl

Version: 1.1

Type: local

Published: 2019/04/23

Updated: 2019/04/23

Dependencies: 12634

Risk Information

Risk Factor: Medium

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:glib, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2019/04/22

Vulnerability Publication Date: 2019/04/22

Reference Information

GLSA: 201904-23