GLSA-201904-22 : OpenDKIM: Root privilege escalation

Medium Nessus Plugin ID 124227

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201904-22 (OpenDKIM: Root privilege escalation)

It was discovered that Gentoo’s OpenDKIM ebuild does not properly set permissions or place the pid file in a safe directory.
Impact :

A local attacker could escalate privileges.
Workaround :

Users should ensure the proper permissions are set as discussed in the referenced bugs.

Solution

All OpenDKIM users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=mail-filter/opendkim-2.10.3-r8'

See Also

https://security.gentoo.org/glsa/201904-22

Plugin Details

Severity: Medium

ID: 124227

File Name: gentoo_GLSA-201904-22.nasl

Version: 1.1

Type: local

Published: 2019/04/23

Updated: 2019/04/23

Dependencies: 12634

Risk Information

Risk Factor: Medium

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:opendkim, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2019/04/22

Vulnerability Publication Date: 2019/04/22

Reference Information

GLSA: 201904-22