GLSA-201811-06 : libde265: Multiple vulnerabilities

Medium Nessus Plugin ID 124212

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201811-06 (libde265: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in libde265. Please review libde265 changelog referenced below for details.
Impact :

A remote attacker could entice a user to open a specially crafted media file using libde265 or linked applications, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All libde265 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-libs/libde265-1.0.3'

See Also

https://github.com/strukturag/libde265/compare/v1.0.2...v1.0.3

https://security.gentoo.org/glsa/201811-06

Plugin Details

Severity: Medium

ID: 124212

File Name: gentoo_GLSA-201811-06.nasl

Version: 1.1

Type: local

Published: 2019/04/22

Updated: 2019/04/22

Dependencies: 12634

Risk Information

Risk Factor: Medium

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:libde265, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2018/11/10

Vulnerability Publication Date: 2018/11/10

Reference Information

GLSA: 201811-06