RHEL 2.1 : pam_smb (RHSA-2003:262)

High Nessus Plugin ID 12417


The remote Red Hat host is missing a security update.


Updated pam_smb packages are now available which fix a security vulnerability (buffer overflow).

The pam_smb module is a pluggable authentication module (PAM) used to authenticate users using an external Server Message Block (SMB) server.

A buffer overflow vulnerability has been found that affects unpatched versions of pam_smb up to and including 1.1.6.

On systems that use pam_smb and are configured to authenticate a remotely accessible service, an attacker can exploit this bug and remotely execute arbitrary code. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2003-0686 to this issue.

Red Hat Enterprise Linux contains a version of pam_smb that is vulnerable to this issue, however pam_smb is not enabled by default.

Users of pam_smb are advised to upgrade to these erratum packages, which contain a patch to version 1.1.6 to correct this issue.

Red Hat would like to thank Dave Airlie of the Samba team for notifying us of this issue.


Update the affected pam_smb package.

See Also



Plugin Details

Severity: High

ID: 12417

File Name: redhat-RHSA-2003-262.nasl

Version: $Revision: 1.21 $

Type: local

Agent: unix

Published: 2004/07/06

Modified: 2016/12/28

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:pam_smb, cpe:/o:redhat:enterprise_linux:2.1

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2003/08/26

Vulnerability Publication Date: 2003/08/27

Reference Information

CVE: CVE-2003-0686

BID: 8491

OSVDB: 2476

RHSA: 2003:262