GLSA-201904-18 : libseccomp: Privilege escalation

High Nessus Plugin ID 124131

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201904-18 (libseccomp: Privilege escalation)

Please review the CVE identifier referenced below for details.
Impact :

Please review the referenced CVE identifier for details.
Workaround :

There is no known workaround at this time.

Solution

All libseccomp users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-libs/libseccomp-2.4.0'

See Also

https://security.gentoo.org/glsa/201904-18

Plugin Details

Severity: High

ID: 124131

File Name: gentoo_GLSA-201904-18.nasl

Version: 1.1

Type: local

Published: 2019/04/18

Updated: 2019/04/18

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:libseccomp, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2019/04/17

Vulnerability Publication Date: 2019/03/21

Reference Information

CVE: CVE-2019-9893

GLSA: 201904-18