Debian DSA-4433-1 : ruby2.3 - security update

High Nessus Plugin ID 124096

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities have been discovered in the Rubygems included in the interpreter for the Ruby language, which may result in denial of service or the execution of arbitrary code.

Solution

Upgrade the ruby2.3 packages.

For the stable distribution (stretch), these problems have been fixed in version 2.3.3-1+deb9u6.

See Also

https://security-tracker.debian.org/tracker/source-package/ruby2.3

https://packages.debian.org/source/stretch/ruby2.3

https://www.debian.org/security/2019/dsa-4433

Plugin Details

Severity: High

ID: 124096

File Name: debian_DSA-4433.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2019/04/17

Updated: 2019/06/19

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 8.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:C/A:C

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ruby2.3, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2019/04/16

Vulnerability Publication Date: 2019/06/06

Reference Information

CVE: CVE-2019-8320, CVE-2019-8321, CVE-2019-8322, CVE-2019-8323, CVE-2019-8324, CVE-2019-8325

DSA: 4433