GLSA-201904-14 : GnuTLS: Multiple vulnerabilities

Medium Nessus Plugin ID 124070

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201904-14 (GnuTLS: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in GnuTLS. Please review the CVE identifiers referenced below for details.
Impact :

Please review the CVE identifiers referenced below for details.
Workaround :

There is no known workaround at this time.

Solution

All GnuTLS users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-libs/gnutls-3.6.7'

See Also

https://security.gentoo.org/glsa/201904-14

Plugin Details

Severity: Medium

ID: 124070

File Name: gentoo_GLSA-201904-14.nasl

Version: 1.1

Type: local

Published: 2019/04/16

Updated: 2019/04/16

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:gnutls, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2019/04/15

Vulnerability Publication Date: 2019/03/27

Reference Information

CVE: CVE-2019-3829, CVE-2019-3836

GLSA: 201904-14