Apache Tomcat 8.5.0 < 8.5.40 Remote Code Execution Vulnerability (Windows)

high Nessus Plugin ID 124063

Synopsis

The remote Windows Apache Tomcat server is affected by a remote code execution vulnerability

Description

The version of Tomcat installed on the remote Windows host is prior to 8.5.40. It is, therefore, affected by a remote code execution vulnerability due to a bug in the way the JRE passes command line arguments to Windows. An unauthenticated, remote attacker can exploit this to execute arbitrary commands. Additionally, it is affected by a cross-site (XSS) scripting vulnerability as the SSI printenv command echoes user provided data without proper escaping.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 8.5.40 or later.

See Also

https://github.com/apache/tomcat/commit/5bc4e6d

http://www.nessus.org/u?56c2ea9d

Plugin Details

Severity: High

ID: 124063

File Name: tomcat_8_5_40.nasl

Version: 1.12

Type: combined

Agent: windows, macosx, unix

Family: Web Servers

Published: 4/16/2019

Updated: 4/11/2022

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: High

Score: 8.4

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 7.7

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:F/RL:OF/RC:C

CVSS Score Source: CVE-2019-0232

CVSS v3

Risk Factor: High

Base Score: 8.1

Temporal Score: 7.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Host/OS

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/13/2019

Vulnerability Publication Date: 3/3/2019

Exploitable With

Metasploit (Apache Tomcat CGIServlet enableCmdLineArguments Vulnerability)

Reference Information

CVE: CVE-2019-0221, CVE-2019-0232

BID: 107906