Adobe Reader <= 2015.006.30482 / 2017.011.30127 / 2019.010.20098 Multiple Vulnerabilities (APSB19-17)

High Nessus Plugin ID 124008


The version of Adobe Reader installed on the remote Windows host is affected by multiple vulnerabilities.


The version of Adobe Reader installed on the remote Windows host is a version prior or equal to 2015.006.30482, 2017.011.30127, or 2019.010.20098. It is, therefore, affected by multiple vulnerabilities.

- Out-of-Bounds Read potentially leading to Information Disclosure (CVE-2019-7061, CVE-2019-7109, CVE-2019-7110, CVE-2019-7114, CVE-2019-7115, CVE-2019-7116, CVE-2019-7121, CVE-2019-7122, CVE-2019-7123, CVE-2019-7127)

- Out-of-Bounds Write potentially leading to Arbitrary Code Execution (CVE-2019-7111, CVE-2019-7118, CVE-2019-7119, CVE-2019-7120, CVE-2019-7124)

- Type Confusion potentially leading to Arbitrary Code Execution (CVE-2019-7117, CVE-2019-7128)

- Use After Free potentially leading to Arbitrary Code Execution (CVE-2019-7088, CVE-2019-7112)

- Heap Overflow potentially leading to Arbitrary Code Execution (CVE-2019-7113, CVE-2019-7125)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Adobe Reader version 2015.006.30493 or 2017.011.30138 or 2019.010.20099 or later.

See Also

Plugin Details

Severity: High

ID: 124008

File Name: adobe_reader_apsb19-17.nasl

Version: 1.6

Type: local

Agent: windows

Family: Windows

Published: 2019/04/12

Updated: 2019/08/20

Dependencies: 20836

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2019-7111

CVSS v2.0

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 8.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:acrobat_reader

Required KB Items: SMB/Registry/Enumerated, installed_sw/Adobe Reader

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/04/09

Vulnerability Publication Date: 2019/04/09

Reference Information

CVE: CVE-2019-7061, CVE-2019-7088, CVE-2019-7109, CVE-2019-7110, CVE-2019-7111, CVE-2019-7112, CVE-2019-7113, CVE-2019-7114, CVE-2019-7115, CVE-2019-7116, CVE-2019-7117, CVE-2019-7118, CVE-2019-7119, CVE-2019-7120, CVE-2019-7121, CVE-2019-7122, CVE-2019-7123, CVE-2019-7124, CVE-2019-7125, CVE-2019-7127, CVE-2019-7128

BID: 107805, 107809, 107811, 107812, 107815