Adobe Reader <= 2015.006.30482 / 2017.011.30127 / 2019.010.20098 Multiple Vulnerabilities (APSB19-17)
Critical Nessus Plugin ID 124008
SynopsisThe version of Adobe Reader installed on the remote Windows host is affected by multiple vulnerabilities.
DescriptionThe version of Adobe Reader installed on the remote Windows host is a version prior or equal to 2015.006.30482, 2017.011.30127, or 2019.010.20098. It is, therefore, affected by multiple vulnerabilities.
- Out-of-Bounds Read potentially leading to Information Disclosure (CVE-2019-7061, CVE-2019-7109, CVE-2019-7110, CVE-2019-7114, CVE-2019-7115, CVE-2019-7116, CVE-2019-7121, CVE-2019-7122, CVE-2019-7123, CVE-2019-7127)
- Out-of-Bounds Write potentially leading to Arbitrary Code Execution (CVE-2019-7111, CVE-2019-7118, CVE-2019-7119, CVE-2019-7120, CVE-2019-7124)
- Type Confusion potentially leading to Arbitrary Code Execution (CVE-2019-7117, CVE-2019-7128)
- Use After Free potentially leading to Arbitrary Code Execution (CVE-2019-7088, CVE-2019-7112)
- Heap Overflow potentially leading to Arbitrary Code Execution (CVE-2019-7113, CVE-2019-7125)
Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.
SolutionUpgrade to Adobe Reader version 2015.006.30493 or 2017.011.30138 or 2019.010.20099 or later.