RHEL 2.1 : kdelibs (RHSA-2003:193)

High Nessus Plugin ID 12400


The remote Red Hat host is missing one or more security updates.


Updated KDE packages that resolve a vulnerability in KDE's SSL implementation are now available.

KDE is a graphical desktop environment for the X Window System.

KDE versions 2.2.2 and earlier have a vulnerability in their SSL implementation that makes it possible for users of Konqueror and other SSL enabled KDE software to fall victim to a man-in-the-middle attack.

Users of KDE should upgrade to these erratum packages, which contain KDE 2.2.2 with a backported patch to correct this vulnerability.


Update the affected packages.

See Also




Plugin Details

Severity: High

ID: 12400

File Name: redhat-RHSA-2003-193.nasl

Version: $Revision: 1.20 $

Type: local

Agent: unix

Published: 2004/07/06

Modified: 2016/12/28

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:arts, p-cpe:/a:redhat:enterprise_linux:kdelibs, p-cpe:/a:redhat:enterprise_linux:kdelibs-devel, p-cpe:/a:redhat:enterprise_linux:kdelibs-sound, p-cpe:/a:redhat:enterprise_linux:kdelibs-sound-devel, cpe:/o:redhat:enterprise_linux:2.1

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Patch Publication Date: 2003/06/17

Reference Information

CVE: CVE-2003-0370

RHSA: 2003:193