Apache ActiveMQ 5.x < 5.15.9 Corrupt MQTT Frame Denial of Service (DoS) (CVE-2019-0222)

high Nessus Plugin ID 123756


The remote host is running a web application that is affected by a denial of service vulnerability.


The version of Apache ActiveMQ running on the remote host is 5.x prior to 5.15.9. It is, therefore, affected by a denial of service (DoS) vulnerability due to improper validation of MQTT frames. An unauthenticated, remote attacker can exploit this issue to cause the broker to stop responding.


Upgrade to Apache ActiveMQ version 5.15.9 or later.

See Also


Plugin Details

Severity: High

ID: 123756

File Name: activemq_5_15_9.nasl

Version: 1.7

Type: combined

Agent: unix

Family: CGI abuses

Published: 4/5/2019

Updated: 6/6/2024

Configuration: Enable thorough checks

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Nessus

Enable CGI Scanning: true

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS Score Source: CVE-2019-0222


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:activemq

Required KB Items: installed_sw/Apache ActiveMQ

Exploit Ease: No known exploits are available

Patch Publication Date: 3/28/2019

Vulnerability Publication Date: 3/28/2019

Reference Information

CVE: CVE-2019-0222

BID: 107622

IAVB: 2019-B-0023-S