PHP 7.3.x < 7.3.4 Multiple vulnerabilities.

Medium Nessus Plugin ID 123755

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 6

Synopsis

An application installed on the remote host is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP running on the remote web server is 7.3.x prior to 7.3.4. It is, therefore, affected by multiple vulnerabilities:

- A heap-based buffer over-read condition exists in php_ifd_get32s in exif.c.

- A heap-based buffer overflow condition exists in exif_iif_add_value in exif.c as a result of improperly checking input length.

Solution

Upgrade to PHP version 7.3.4 or later.

See Also

http://php.net/ChangeLog-7.php#7.3.4

Plugin Details

Severity: Medium

ID: 123755

File Name: php_7_3_4.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 2019/04/04

Updated: 2019/10/30

Dependencies: 48243

Risk Information

Risk Factor: Medium

VPR Score: 6

CVSS Score Source: CVE-2019-11034

CVSS v2.0

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.1

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/04/04

Vulnerability Publication Date: 2019/04/04

Reference Information

CVE: CVE-2019-11034, CVE-2019-11035

BID: 107794