GLSA-201903-22 : ZeroMQ: Code execution

High Nessus Plugin ID 123428

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201903-22 (ZeroMQ: Code execution)

Please reference the CVE for details.
Impact :

Please reference the CVE for details.
Workaround :

There is no known workaround at this time.

Solution

All ZeroMQ users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-libs/zeromq-4.3.1'

See Also

https://security.gentoo.org/glsa/201903-22

Plugin Details

Severity: High

ID: 123428

File Name: gentoo_GLSA-201903-22.nasl

Version: 1.1

Type: local

Published: 2019/03/28

Updated: 2019/03/28

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:zeromq, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2019/03/28

Vulnerability Publication Date: 2019/01/13

Reference Information

CVE: CVE-2019-6250

GLSA: 201903-22